Curious as to why my Pulse X is behaving strangely

Discussion in 'Squonkers' started by rocketyos, May 25, 2019.

  1. rocketyos

    rocketyos Well-Known Member 1 year member

    Joined:
    Aug 3, 2017
    Messages:
    375
    Likes Received:
    440
    I really like this mod. It's compact enough and lightweight. It's easy to use. I like that it takes 21700 batts. I take an extra with me during the day and the set up is just right. I have a dark red G10 and I like the feel of the material. But it's acting weird.

    1) When I leave the mod alone for a while, it jumps from the watts I set it at to 42w. It also now and then asks if I've installed a new coil. This happens whether or not I lock the mod, btw.
    2) The coils in the Pulse X RDA gunk up big time. It doesn't matter what coils I use. They gunk up faster than, for example, coils on other RDAs or RTAs. And I'm using the same juice in all of them.

    I had to have my Pulse X repaired. I dropped it a few times and had the juice spill all over the place. The repair guy did a good job. That said, it was doing all these weird things before I dropped it. And now that it's all fixed, it's doing it again.

    It works, so I just keep changing the watts back to where I want it and indicating that I haven't changed the coil. I'm just wondering what's going on here.
     
  2. Vapin4Joy

    Vapin4Joy Well-Known Member 1 year member

    Joined:
    Jul 19, 2017
    Messages:
    16,640
    Likes Received:
    59,847
    Hiya Rocket,
    Could be one or more things not right. How old is the battery your using, may be it's not holding amps or nosing over. Perhaps a bad 510, try cleaning it with a Q-Tip dipped in alcohol. Check the battery sled/contacts, clean. Or the chip has failed.
    Post more info, type of battery, does it act up with all RDA's and or Tanks?
     
  3. rocketyos

    rocketyos Well-Known Member 1 year member

    Joined:
    Aug 3, 2017
    Messages:
    375
    Likes Received:
    440
    I'm using a Samsung 3000 mAh battery, purchased in January of this year from a reliable seller who doesn't sell fake batts. I don't think it's the battery. I have much older 18650 batts that still do a decent job. I'll try cleaning and testing it with other attys. Thanks for the suggestions.
     
    Vapin4Joy likes this.
  4. rocketyos

    rocketyos Well-Known Member 1 year member

    Joined:
    Aug 3, 2017
    Messages:
    375
    Likes Received:
    440
    So I tested the mod with the serpent elevate RTA and wasp nano RDA I haven't had any issues with either atty. I think the problem is that the Pulse X RDA just gets too hot. I don't know the science behind that but the attys that stay cool don't impact the mod's performance.
     
    Vapin4Joy likes this.
  5. Vapin4Joy

    Vapin4Joy Well-Known Member 1 year member

    Joined:
    Jul 19, 2017
    Messages:
    16,640
    Likes Received:
    59,847
    Most likely a bad build/coil or the coil is shorting out.
     
  6. rocketyos

    rocketyos Well-Known Member 1 year member

    Joined:
    Aug 3, 2017
    Messages:
    375
    Likes Received:
    440
    Thanks. I'll change coils and see if I get better performance. Will come back with more feedback. :)
     

Share This Page